TeknologjiRrjeteWeb

Sistemi i Emrave të Domaineve

Sistemi i Emrave të Domaineve (DNS) është një shërbim emrash hierarkik dhe i shpërndarë që ofron një sistem emërtimi për kompjuterë, shërbime dhe burime të tjera në internet ose rrjete të tjera të Protokollit të Internetit (IP).

O

Oltion Elezi

·7 min lexim

1 shikime
Sistemi i Emrave të Domaineve

Sistemi i Emrave të Domaineve (DNS) është një shërbim emrash hierarkik dhe i shpërndarë që ofron një sistem emërtimi për kompjuterë, shërbime dhe burime të tjera në internet ose rrjete të tjera të Protokollit të Internetit (IP). Ai shoqëron informacione të ndryshme me emra domenesh (vargje identifikimi) të caktuar për secilin prej entiteteve të shoqëruara. Më e spikatura është se ai përkthen emrat e domeneve të memorizuara lehtësisht në adresat numerike IP të nevojshme për gjetjen dhe identifikimin e shërbimeve dhe pajisjeve kompjuterike me protokollet themelore të rrjetit. Sistemi i Emrave të Domaineve ka qenë një komponent thelbësor i funksionalitetit të internetit që nga viti 1985.

Sistemi i Emrave të Domaineve delegon përgjegjësinë e caktimit të emrave të domeneve dhe hartëzimit të këtyre emrave në burimet e internetit duke caktuar servera autoritar emrash për secilin domen. Administratorët e rrjetit mund të delegojnë autoritetin mbi nën-domenet e hapësirës së tyre të caktuar të emrave në servera të tjerë emrash. Ky mekanizëm ofron shërbim të shpërndarë dhe tolerant ndaj gabimeve dhe është projektuar për të shmangur një bazë të dhënash të vetme të madhe qendrore. Përveç kësaj, DNS specifikon funksionalitetin teknik të shërbimit të bazës së të dhënave që është në thelbin e tij. Ai përcakton protokollin DNS, një specifikim të detajuar të strukturave të të dhënave dhe shkëmbimeve të komunikimit të të dhënave të përdorura në DNS, si pjesë e suitës së protokolleve të internetit.

Interneti mirëmban dy hapësira kryesore emrash, hierarkinë e emrave të domenit dhe hapësirat e adresave IP. Sistemi i Emrave të Domenit mirëmban hierarkinë e emrave të domenit dhe ofron shërbime përkthimi midis saj dhe hapësirave të adresave. Serverat e emrave të internetit dhe një protokoll komunikimi zbatojnë Sistemin e Emrave të Domenit. Një server emrash DNS është një server që ruan të dhënat DNS për një domen; një server emrash DNS përgjigjet me përgjigje ndaj pyetjeve në bazën e të dhënave të tij.

Llojet më të zakonshme të të dhënave të ruajtura në bazën e të dhënave DNS janë për fillimin e autoritetit (SOA), adresat IP (A dhe AAAA), shkëmbyesit e postës SMTP (MX), serverat e emrave (NS), treguesit për kërkimet e kundërta të DNS (PTR) dhe pseudonimet e emrave të domeneve (CNAME). Edhe pse nuk është menduar të jetë një bazë të dhënash me qëllim të përgjithshëm, DNS është zgjeruar me kalimin e kohës për të ruajtur të dhëna për lloje të tjera të të dhënave ose për kërkime automatike, siç janë të dhënat DNSSEC, ose për pyetje njerëzore siç janë të dhënat e personit përgjegjës (RP). Si një bazë të dhënash me qëllim të përgjithshëm, DNS është përdorur gjithashtu në luftimin e email-eve të pakërkuara (spam) duke ruajtur lista bllokimi. Baza e të dhënave DNS ruhet në mënyrë konvencionale në një skedar teksti të strukturuar, skedarin e zonës, por sisteme të tjera të bazës së të dhënave janë të zakonshme.

Sistemi i Emrave të Domaineve fillimisht përdorte Protokollin e Datagramit të Përdoruesit (UDP) si transport mbi IP. Shqetësimet për besueshmërinë, sigurinë dhe privatësinë lindën përdorimin e Protokollit të Kontrollit të Transmisionit (TCP), si dhe shumë zhvillime të tjera të protokolleve.

Funksioni

Një analogji e përdorur shpesh për të shpjeguar DNS-in është se ai shërben si libër telefonik për internetin duke përkthyer emrat e hosteve të kompjuterëve të përshtatshëm për njerëzit në adresa IP. Për shembull, emri i hostit www.example.com brenda emrit të domenit example.com përkthehet në adresat 93.184.216.34 (IPv4) dhe 2606:2800:220:1:248:1893:25c8:1946 (IPv6). DNS mund të përditësohet shpejt dhe në mënyrë transparente, duke lejuar që vendndodhja e një shërbimi në rrjet të ndryshojë pa ndikuar te përdoruesit fundorë, të cilët vazhdojnë të përdorin të njëjtin emër host. Përdoruesit përfitojnë nga kjo kur përdorin Lokatorë Uniformë të Burimeve (URL) dhe adresa email-i kuptimplotë pa pasur nevojë të dinë se si kompjuteri i lokalizon në të vërtetë shërbimet.

Një funksion i rëndësishëm dhe i kudondodhur i DNS është roli i tij qendror në shërbimet e shpërndara të internetit, siç janë shërbimet cloud dhe rrjetet e ofrimit të përmbajtjes. Kur një përdorues hyn në një shërbim të shpërndarë të internetit duke përdorur një URL, emri i domenit të URL-së përkthehet në adresën IP të një serveri që është afër përdoruesit. Funksionaliteti kryesor i DNS-së i shfrytëzuar këtu është se përdorues të ndryshëm mund të marrin njëkohësisht përkthime të ndryshme për të njëjtin emër domeni, një pikë kyçe divergjence nga një pamje tradicionale e librit telefonik të DNS-së. Ky proces i përdorimit të DNS-së për të caktuar serverë proksimalë për përdoruesit është çelësi për të ofruar përgjigje më të shpejta dhe më të besueshme në internet dhe përdoret gjerësisht nga shumica e shërbimeve kryesore të internetit.

DNS pasqyron strukturën e përgjegjësisë administrative në internet. Çdo nën-domen është një zonë autonomie administrative e deleguar një menaxheri. Për zonat e operuara nga një regjistër, informacioni administrativ shpesh plotësohet nga shërbimet RDAP dhe WHOIS të regjistrit. Këto të dhëna mund të përdoren për të fituar njohuri mbi dhe për të ndjekur përgjegjësinë për një host të caktuar në internet.

Histori

Përdorimi i një emri më të thjeshtë dhe më të paharrueshëm në vend të adresës numerike të një hosti daton që nga epoka e ARPANET-it. Instituti i Kërkimeve Stanford (tani SRI International) mirëmbante një skedar teksti të quajtur HOSTS.TXT që lidhte emrat e hosteve me adresat numerike të kompjuterëve në ARPANET. Elizabeth Feinler zhvilloi dhe mirëmbau direktorinë e parë ARPANET. Mirëmbajtja e adresave numerike, e quajtur Lista e Numrave të Caktuar, u trajtua nga Jon Postel në Institutin e Shkencave të Informacionit (ISI) të Universitetit të Kalifornisë Jugore, ekipi i të cilit punoi ngushtë me SRI-në.

Adresat u caktuan manualisht. Kompjuterët, duke përfshirë emrat e hosteve dhe adresat e tyre, u shtuan në skedarin kryesor duke kontaktuar Qendrën e Informacionit të Rrjetit SRI (NIC), të drejtuar nga Feinler, nëpërmjet telefonit gjatë orarit të punës. Më vonë, Feinler krijoi një drejtori WHOIS në një server në NIC për marrjen e informacionit në lidhje me burimet, kontaktet dhe entitetet. Ajo dhe ekipi i saj zhvilluan konceptin e domeneve. Feinler sugjeroi që domenet duhet të bazohen në vendndodhjen e adresës fizike të kompjuterit. Kompjuterët në institucionet arsimore do të kishin domenin edu, për shembull. Ajo dhe ekipi i saj menaxhuan Regjistrin e Emërtimit të Hosteve nga viti 1972 deri në vitin 1989.

Në filli të viteve 1980, mirëmbajtja e një tabele të vetme të centralizuar pritëse ishte bërë e ngadaltë dhe e vështirë për t’u përdorur, dhe rrjeti në zhvillim kërkonte një sistem të automatizuar emërtimi për të adresuar çështjet teknike dhe të personelit. Postel drejtoi detyrën e arritjes së një kompromisi midis pesë propozimeve konkurruese të zgjidhjeve për Paul Mockapetris. Në vend të kësaj, Mockapetris krijoi Sistemin e Emrave të Domaineve në vitin 1983, ndërsa ishte në Institutin e Shkencave të Informacionit të USC-së.

Task Forca për Inxhinierinë e Internetit publikoi specifikimet origjinale në RFC 882 dhe RFC 883 në nëntor 1983. Këto u përditësuan në RFC 973 në janar 1986.

Në vitin 1984, katër studentë të UC Berkeley, Douglas Terry, Mark Painter, David Riggle dhe Songnian Zhou, shkruan implementimin e parë të serverit të emrave Unix për Domainin e Emrave të Internetit Berkeley, i njohur zakonisht si BIND. Në vitin 1985, Kevin Dunlap i DEC e rishikoi në mënyrë thelbësore implementimin e DNS. Mike Karels, Phil Almquist dhe Paul Vixie morën përsipër mirëmbajtjen e BIND. Internet Systems Consortium u themelua në vitin 1994 nga Rick Adams, Paul Vixie dhe Carl Malamud, posaçërisht për të siguruar një shtëpi për zhvillimin dhe mirëmbajtjen e BIND. Versionet e BIND nga versioni 4.9.3 e tutje u zhvilluan dhe mirëmbaheshin nga ISC, me mbështetjen e ofruar nga sponsorët e ISC. Si bashkë-arkitektë/programues, Bob Halley dhe Paul Vixie publikuan versionin e parë të gatshëm për prodhim të versionit 8 të BIND në maj 1997. Që nga viti 2000, mbi 43 zhvillues të ndryshëm kryesorë kanë punuar në BIND.


Lexoni më tej

Arkitektura zero besimi

Arkitektura me besim zero (ZTA) është një strategji projektimi dhe zbatimi të sistemeve IT. Parimi është që përdoruesit dhe pajisjet nuk duhet të jenë të besueshme si parazgjedhje, edhe nëse janë të lidhur me një rrjet të privilegjuar siç është një LAN i korporatës dhe edhe…

Firewall (informatikë)

Në informatikë, një firewall është një sistem sigurie rrjeti që monitoron dhe kontrollon trafikun hyrës dhe dalës të rrjetit bazuar në rregulla sigurie të konfigurueshme.

Rrjet privat virtual

Një rrjet privat virtual (VPN) është një rrjet mbivendosës që përdor virtualizimin e rrjetit për të zgjeruar një rrjet privat në një rrjet publik, siç është interneti, nëpërmjet përdorimit të protokolleve të enkriptimit dhe tunelimit.

O

Shkruar nga

Oltion Elezi

Founder & CEO of Elei Soft